Rename 'Current layer' condition

The “Current layer” condition allows you to check if the object is on the specified layer:

However, since you choose which layer you’re checking against, this really has nothing to do with the current layer. You could check if the object is on a layer that’s hidden.

So using the word ‘current’ in the condition name is misleading. I recommend changing it (perhaps to something like “Object is on layer” instead).

1 Like

Hi, I dont know if I’m right but here’s my thought :

When choosing an object, it shows me what I want to check about this object. Its position, its size, its current layer…

So I guess current layer stands for : check if the object’s current layer is egual to = “whateverlayername”

Current layer is about the object’s current layer


Ah, that’s a good point…

1 Like