RuntimeError: memory access out of bounds (Solved)

Hello. I’ve been working well with the program lately, I had no errors, yesterday when I finished using the program I turned off the PC as usual. Today I turn it on, I open the program, I want to put my game in preview and it doesn’t start.
It stays charging as in the photo and stops charging.

Yesterday the only thing I did was change the animations of the objects that go in the interface in each one of the levels.
On the other hand, to test if the error is in the global variables, I zero some variables, like having a key, and another removes my immortality. They made me think that the problem is in the global variables because I can’t start the preview game in any scene. By resetting some global variables to zero, my game went straight to black screen with this error

I left it for several minutes and since I didn’t get any more data I close the preview, I try to access the global variables and the program freezes and I have to close everything.

fixed up. One of the levels had variables as condition and animations as actions that no longer existed.

After fixing it, it worked fine as long as I kept the program open, preview worked fine for me. But I closed the program and reopened it and I get the same problem

Hi there,
Did you try rebooting your computer and updating GDevelop?
Does GDevelop work fine except for preview?

Hello !! Yes, I already restarted the pc,
Is there a way to directly locate which variable is failing? It seems the conflict was over a variable, but I’m just speculating.
The editor works fine, but when I go to preview, it stays loading like in the first photo, and it just stops loading. On very few occasions it started, with the error that I put in the second photo.
When I fixed some variables that were being the condition for animations that no longer existed, I changed them and the preview worked perfectly again, all the scenes. When closing the program and reopening it I have the same problem.

the program updates itself.
I have the latest version

No, I don’t think there’s a way to get more details about where your error is. Check your events sheets, check the variables editors, check the properties/behaviors. :mag:
Or if you have a recent backup, use it.
If you don’t back up regularly, consider doing so. :slight_smile:
If you use unusual characters, or if you use “quotes” where they are not needed, it can cause such issues as well.
Good luck!

I hope my game hasn’t broken. Well starting tomorrow I will do an exhaustive analysis, thank you very much. If I get any signal I will add it.

I have found that the error is in one of the scenes. When I delete that scene, the preview works perfectly, I save the game, close and open the program, go to preview and it works fine.
I made a copy of the game before deleting that scene, the events are fine with the naked eye, but I still deleted all the events and the preview still didn’t work. I deleted all the objects from the scene, and from the panel, and the preview does not work, it loads as in the first photo and stops loading.
So the problem must be in the programming part, something must have changed there, something I never changed because I don’t even know what section of the program the programmers go into to program their game.
It’s a relief that the game isn’t completely broken. But it would be great not to lose the level.

That shows up for in developer tools when I go to preview it starts loading and stops loading.

This is going to sound weird but it is. I open the copy of my game, the one with the deleted scene, I go to preview, well, and as I said, it works fine. I close the preview, open the main game with the error scene, go to preview and it works fine…

All good, then, problem solved. :sunglasses: :rofl:
Did you check the scene variables too? Right-click in the scene/properties/variables.

not!! xD it’s not solved. I must first open the copy of the game where I deleted the problematic level. I go to the preview, I see that it works fine, I close the preview.
Then I open the original game, the one with the problematic level, and the game works fine. But I have to do the first step first, otherwise it won’t load the original game, that’s why I say it’s very weird.
It’s not resolved because this shouldn’t work like that and I don’t know what’s going on.

i checked everything. I left the problematic level completely empty and the game doesn’t work.
I have to clear the level for the game to work. Or what I have already mentioned about going to the copy I made of the game where I have deleted the level, go to preview, close preview.
Then open the original game, go to the preview and amazingly it works.
In other words, I have to open a game first, and then another, for it to work, I don’t find any sense in it, but it works, even so I have to keep looking because this shouldn’t work like that, besides, it’s a mess. That’s why I have to delete the level completely, or keep looking, but I don’t know where to look anymore.

I see. If you’re willing to share the zipped project, we can investigate further.
Aside from that, I’ll assume that your scene got somehow corrupted. :person_shrugging:
Try to duplicate the scene (right-click on the name), see if that helps.
If not, try to create a new scene, and copy-paste the scene elements and the events. It might do the trick.

Coincidentally that’s what I’m doing. copying and pasting everything to a new scene. But it keeps giving me the same error. So I’m ruling out what to copy and what not. Thank you very much, I will keep trying, I understand that it would be much easier and less tedious to have the project yourselves to be able to review it directly.

What a bummer, if I delete all the other levels, the title scene, everything, and just leave the level that I think is problematic, the
level works well, this is exhausting xD for me the problem is in the programming section. If I give you my project, how long will it take them to start reviewing it? If so, where should I post the link?

Do File/Save as to a new folder, then zip it and upload it on or similar.
I can’t give you any timeline for the devs though. :person_shrugging:

Whenever I create a scene, it’s actually a duplicate scene from previous levels that worked fine, I delete the objects inside the scene and I’m left with the events and panel objects already created. When I finish the game completely, I will of course remove the events and items I didn’t use in each duplicate level.
This time I created a completely empty new scene and copied everything from the faulty scene to the new scene, coincidentally I forgot about an enemy.
I removed the faulty level.
I tried the game and it works fine, but I was missing that one enemy that, like so many others, is everywhere in the scene. so i did the same procedure again to create a new scene etc.
I copied and pasted everything, deleted the faulty level, and… again problem with the first photo, it loads and stops loading. Probably the conflict is from that enemy, but I did not find where it fails.
I agree that the level was corrupted.
Now, to get my game back to the way it was before the problems started, all I had to do was copy and paste everything into the new scene, except for the conflicting enemy. recreate the enemy and bring him back to the scene. Luckily I didn’t have to sacrifice level. Just one object.

1 Like