Saving only works in web exports and preview

So, I tried making a little program to plan what i work on each week, and i tried implementing a save feature, but somehow, it only works on the preview tab and the web exports, and when i export it to desktop it doesn’t ever save properly. When i close the preview and open it again the saving works as intended, same thing with the web export. But every time i close the windows build, it’s like it deletes the save file. Worst part, it only happens with this project, as i tried exporting the save load template to windows, and it works perfectly.
Am I doing something wrong? Is this an engine thing? Is this specific project cursed for no reason?

This is the events in my project, i don’t see why it wouldn’t work
I also tried loading the storage into memory before loading and closing it after loading, but it doesnt work either.
It’s almost exactly the same as the template, and despite the template working, this one doesn’t.
There’s no other events referring to the storage, and i just think it’s incredibly odd that it does work in web exports and the preview window.
I would really appreciate if anyone could help, as it’s had me stumped for a few days now

I made a new project file, to check if it was only that specific one that didnt work (since the templates worked just fine) and… It works??? like it still doesn’t work on that specific file but… the rest work just fine, guess that one was cursed specifically by the ancient gods

I recommend adding a trigger once condition to your “Left mouse button was released” event. This is because right now the events are writing the same data every frame the cursor touch is on one of the objects because there are no other conditions stopping it from running, trigger once with only save the data once when the cursor touch is on the object.

I will try adding that, but that would still not solve the problem, as even if it saves the data a lot of times its still getting erased after closing the game, or at least i dont think it would solve it
Update: I added that, and it didn’t do much, thanks for the suggestion tho

Hmmm… I’m not sure then. You can always try using Firebase (googles cloud storage system, it’s free) as it is integrated into the GDevelop IDE.