Side character not returning (Let me explain...)

So in my game, the main character has a partner that supposed to show up during cutscenes.

There’s a command called > for him to walk out of the player character FF1 style. This event is supposed to be called during certain dialogue events. such as this one.

the command in action, along side the “returning” error :arrow_down:

niru diappear bug

after the dialogue event,an event called <> is called and he’s supposed to what back into the player character, but it doesn’t work.

The walking OUT works, but not Walking back IN.

Here are my events:

Niru appears

Niru returns (doesn’t work)

what should I do? Also if you need me to show anymore events, let me know.

(Why do I get the feeling that this might take awhile…?)

From what I can tell, it appears to be an issue with Yarn. I had a similar issue myself where commands at the end of a node fail to be called. What I ended up doing was checking if the dialogue had ended (invert if dialogue is running condition), then adding any other actions. I’m aware this is unorthodox, and may not even be the problem, but from what I can get from your events, they appear to be fine.

Something along the lines of:
If dialogue is not running Then move Niru

Please lemme know if I need to explain this better, and if the problem persists! :slight_smile:


Can you show me an example?

Checking it over, it seems like I messed up my example anyways so this should help. Something along these lines should work, but you are free to adjust as needed.

Lemme know if you need anything else!


I’ll give this a shot whenever I get the chance.

I don’t think it’s a good Idea to have like that, there’s other conditions that need to be met.

I tried adding the “Dialogue is running” event, but it didn’t work.

I had a look at your project a while back, and there was a similar problem when you went into boss fight mode. The last string in the dialogue was a command. It got ignored by GDevelop. The only way I got it to action/acknowledge the command was to put some dialogue text after it, so that the action was the second to last dialogue item

I think you’ll find the same will happen here. I don’t know if it’s a yarn bug or just how it’s supposed to work, but you could raise it as a bug with a simple example.

I actually did put something after the command. but it didn’t work either way.

Could you go into more detail?

In the boss fight example, I added a “…” as the last line in the dialogue. I think that fixed it.

I’ll have a further look later on once I’m off work.

I also did that for this dialogue. but despite that it didn’t work.

If you want, I can send you a copy of the project again.

Put the “…” in double quotes and see if that makes a difference. Otherwise, yes, share the project again and I’ll see what I can do for a workaround for what appears to be a shortcoming of yarn.

1 Like

Alright, I’ll give it a shot when I get a chance.