Smooth movement player (video)

I can’t figure out why my player movements are not smooth.
You can see the problem here

I have tried multiple configuration.

Resolution : 320x180 with player assets around 16x16 and 24x24
Resolution : 160x90 with lower pixel assets.

I have tried this type of movement :

with this type of behavior (TopDownMovement)

I have tried too the Behavior “Add a force”, "Add a force(angle), moving by changing X & Y Position like (add TimeDelta() *70

there is no way to make smooth movement ?
Also i have tried to export my game and still same problem.

Did i’m looking at the wrong place ?
Seriously I’m running out of ideas to find a solution lol so if you can help me a bit it would be cool !!

Thank you

I think your game is at such a small resolution you’re hitting the limits of what even subpixel rendering can do.

Try doubling the resolution of the game as a test and see if it seems smoother to you.

Thank you for you help.

Unfortunately, i have set a resolution 640x360 there is a little bit smoother but the problem is still here.
You tell me to increase the resolution, does that mean that it is impossible to create low resolution games with gdevelop?
Another idea where I can investigate ?

It’s weird because i’m sure most of people use low resolution for their game and I haven’t seen anyone complain about such a thing.
Download Project

To be clear, 320x180 is smaller than even NES resolution in pixels, so you’re not just doing “small resolution” you’re doing “tiny resolution”, which is more problematic.

You can look at Super Mario Brothers here, if you watch the bricks as they move, the movement isn’t actually smooth, it’s slightly stuttery as it scrolls. I Play - Super Mario Bros. - On Original Nintendo NES Hardware - YouTube

This is because the game couldn’t do subpixels, so despite the image being blown up onto a TV, the bricks still can only move 1 pixel at a time.

A lot of game devs today “fake” small resolution but actually have higher resolution, or at least higher than NES resolution. (Shovel Knight, for instance, was 400x240).

All of that said, while your low resolution will cause some stuttering, I’m also seeing other issues:

You have default controls enabled, but also have events trying to simulate controls. This means your control actions are occurring twice.

Here’s an example project I made real quick at 320x180 with no controls in the event sheet, and the player moves around much smoother than yours:

1 Like

Ok thank you.

I have miss to disable the simulate control because it’s just a simple project to test why it’s going on (my main project have custom control) so that’s why i forgot to change.

For the resolution i have a better understand of what you are telling me.
Whatever I will try to find a resolution that can match properly with a 16: 9 fullscreen and make my assets less jerky (from what I understand a higher resolution will fix this) I’m going to redo an asset and change my resolution to see if it’s better.

thank you again for your clarification

1 Like

No worries! I think you’re just experiencing a combination of the two things (subpixel movement due to the small resolution AND conflicting events).

You might also just uncheck “default controls” and see if that behaves better for you as well.

Hopefully the above helps.