[Solved] A serious bug in the MarchingSquaresBehavior and shapepainter

In the platform painting in the official case, complete copy learning is performed. When using shape painter to draw shapes that can be collided, the character cannot move, or the character cannot collide with the drawing pattern.

Although the settings are the same as the official case, even if the collision drawing is correct, the character still does not collide, falls directly, or cannot operate the character.
When you add the drawing effect first, after running, add the Platform, then there will be no collision.
When you first add paint effects and Platform, run, then the character can not move. At present, I don’t know how to solve this problem. I don’t know which part caused the problem.

It is clear that as long as MarchingSquaresBehavior is used with shapepainter, the background always displays errors, although it does not cause the operation to crash

What’s even weirder is that if it’s an official document, it doesn’t have any errors

This is the logic diagram

The problem was that the draw command was at the Mouse X & Y position. The mouse position functions need a layer and camera as parameters. They were missing. Once added it worked fine :

Whoops, I missed another vital fix - there were also 2 check boxes on the ShapePainter object that needed to be unchecked :