[Solved] Admob Banner not showing

Hi Guys, I just discovered Gdevelop a month ago and so far i’m lovin’ it!
I’m about to finish a game, but I’m having some trouble puttin ads on it.

Here some points:
→ Made my account a week ago, I think I’m already able to show banner ads.
→ Already double-checked the app ID and Ad ID they are not the same and are equal to the ones my Admob account.
the code:

Is there any relation between the banner and the Z-Index? Like, could some of my objects like the background be in front of it?


Not sure about the z-order… I think we have no graphic control over the ads, so they should always appear on top.
But you should activate the test mode, and make sure to export for testing.

Thanks for replying!

Just tried that:

Here’s the pic of the game running in my android:

No sign of the Ad, and no clue why :confused:

Maybe load and show cannot be in the same event?
Why not switch “display on load complete” to yes and delete the show action?

I’ve already tried show on load in both test mode and the real ad, noit worked, I was just trying a different approach :confused:

I’ll Try putting show on a different event.

I was thinking in asking for google admob support, but if even on test mode it doesn’t work, i dont think it’s on their side.

What the hell, lol, I’m having the same problem right now.

Already tried using different events, loading then setting a variable to 1 then when variable is 1 show, also doesn’t work. Bummer :confused:


What could it be? Maybe something with the resolution? Your game Res is also smaller than your android screen res?

Just don’t know what else to try…

Nope :slight_smile: I fixed the resolution earlier. To fix yours refer to this post: Full screen in all mobile - #13 by Tic_Games

Mah Aspect ratio is fine too, and in fullscreen.

Did you set your app id? (without quotes) :confused:

Yes :confused:
No quotes:

1 Like

Before search bug in your events start by fill the example admob with your admob keys.

If you see ads in the exported game with the example with yours admob keys, the problem is in your events.
If you canno’t see ads, maybe your google admob account have not yet ads to display.
For moreabout admob for GD5 read the documention.

All ads from admob are always on top, a sprites canno’t be over a ads.

Thanks for replying!
It’s great to finally don’t have doubts about the Z-oroder. The testing was driving me crazy.

I’ll try redoing it.
One small doubt… Will test mode not work if my google ad mob account is not approved?

'Cause even n test mode I don’t see a thing :confused:

Just got a interesting result…

I took the exemple and replaced the banner on it with mine.

It just keeps on the loading forever. Never gets ready. It means the problem is on Google ?

Probably yes, your admob account was created when ?

I’ve created it about a week ago.

Problem solved!
Just got it working by adding a payment method in mah admob account. Not sure why, just read in some foruns that it happens with a lot of people in different applications. Thanks for your support!

This is in the documentation.
That’s mean you havent read all the page…