[SOLVED]Admob suddenly not showing in open test mode

As the title describes i’m having an issue with the admob interstitial suddenly not showing anymore. This happend some days after the game had been in open test mode on google play store, and i uploaded a new version/update.
As far as I can see there is no problem in having real ads showing in open test mode on play store.
I’ve implemented the ca-app-pub-1111…~222… code in the properties panel and implemented the other ca-app-pub-1111…/2222… code in in the action: Load interstitial in the app unit ID “…” I’ve also uploaded a .txt file on the root of my webside for verification for Admob.
Is there anybody else here that has had this problem before?

UPDATE! Tried with the the latest apk instead and the interstitial is working. Could it be something with the signing key when uploading the .abb file on play console? (I used the signing option: New upload key, in the gdevelop compiler)

Somehow the ads started showing after 5-6 days. Not sure why though. Anyway, all good now.