[Solved] Admod doesn't show

Hello, everybody \o/

I am in a bad situarion here because i can’t figure out how to make the admob work. I’ve tried everything i saw here in the forum, even downloaded and compiled the example but even it didn’t work at all.

Even the test ad doesn’t show in my .apk. I’m compiling the game manually using cordova as shown in the tutorial and everything. I guess that this must be the problem, do i need a special module for the cordova so admobs can work?


1 Like

Sorry guys, it’s already working.

All i’ve done was delete the folder where i’ve exported the game and made the android package. So after that i’ve had to do everything again to set up the cordova on the folder. And then it worked just fine.

I hope that this post helps anyone in the future, haha.

I need help with admob too

i got the same result as you do. i load two banners at top and bottom with test id at the start of game and set it to show when load complete and exported my game for android but when i run it in my mobile i see nothing, no test ads are shown.
can you tell me how you fixed it step by step?

Thank you

Hello, Mucy.

Are you exporting it automatically or manually?

i have tried both ways
and i used phonegap for manually

I don’t know if the adobe phonegap supports the admob module. I’ve been building my game using cordova since the beginning. I just had to delete everything from the folder i’ve exported the game and make the platform environment there again. When the cordova admob module reinstalled it worked just fine.

Anyway, can you show your conditions to show the ads?

to see that admob is working or not i just placed them at the beginning of the scene
load command after that show command

Can you show a print?

overlap is set to no, can that be a problem cause i have turned off the auto resizing of the screen