[Solved] Ads don't appear in the app

Hi, GDevelopers.
Using GDevelop 5 to learn how to implement ads in my game but when I load any scene and click on any button, except those that change the scene (go to reward videos, to interstitials etc), nothing happens.

Please, read the last message.


Yes it’s normal, you should read how it work on Wiki :slight_smile:


Thank you! But the thing is I’ve read it and can’t make this working. I added app id and unit id to the corresponding spots but when I try to load and show them in my game neither banners nor rewarding videos do appear.
Tested a built app on my android phone.

Wiki say :
It may take a few days for the Admob service to provide ads to appear in your application, especially video content.

1 Like

Still no ads on android. I need to implement only the video reward ad but both don’t work. Checked app id and unit id’s for both ads.

Solved. Check your AdMob account. You should fill in all required information including Payment.
Your Home page must contain this2

1 Like