[Solved] Animations stuck on 1st frame

I started animating my character and every animation worked fine so far except for two:

  1. The AttackLeftClick one which is supposed to be a sword swing and the character moves forward a bit, but it only moves the play by a few pixel to the right ( i think it only shows 1st

  2. The Run animation which is stuck in the 1st frame and makes my character look like he’s gliding on ice instead of running

Here’s why this is happening:

The way "Change animation..." works is that if the animation is set to the same as it is currently, nothing happens; the animation continues playing as normal. When the animation changes, the frame is reset to the first one of the new animation.

You are setting the animation to “Walk” or “Idle” every frame, and then changing Run or Attack. When you change the animation the second time, it resets the animation to the first frame.

Try using a trigger once on each of these two events:

1 Like

thank u so much, it worked!