[SOLVED] Camera Shake not working?

When I press S my camera should be shaking but nothing shake why??
There is no other events.
I have 2 layers base and UI.
Do I need to setup something?

Do you have any objects on the scene, and if so, on which layers?

I placed an enemy on the base layer and text on UI layer but when I pressed and released “s” key nothing happened

And My Camera Shake doesn’t look like the tutorial video idk why?
The video:


it looks totally different.

In the video the action is searching for “shak”, whereas you haven’t.

The difference in parameters could be because it’s been updated. But that’s speculation.

I don’t know why your scene isn’t shaking. I tried it out and it worked fine for me. Sorry, that’s not the answer you’d like, but if I cannot replicate the issue then I can’t investigate.

Do you have the same parameters as the video or the updated one?


I was dumb, I had to use an action to config and make UI layer shake not Base layer shake and I set shaking time easing to too high resulting in nearly nothing move.

Thank you for answering me.

1 Like