[SOLVED] Clipboad read not working

I was following a tutorial made by The Gem Dev on YouTube on how to create a multiplayer game when I got a problem with the clipboard extension

(i’ll put my view in the comments because i can oly put 1 image in a post
Does someone know why i don’t see the readtext function?
obviously, YES i have the clipboard extension installed.

My view:

when you install an extension, this extension is available in that project only. There not installed to GDevelop directly.

so check again, if you have it installed in this particular project.

I just tried it myself and it looks the extension got changed.
Seems you have to use the clipboard events separately and store the values in a variables and then set the text to that variable.

oh, thx, hope that’ll work!

uhm, it always shows 0 :sweat_smile:

it states that the action is asynchronous, which means, you need to wait for it.
that could look like this:

that being said, it does not work for me, anything i copy does not show up in that variable.
I dont know, if it only works on exported games, html only or whatever. Likely some kind of access problem.
Maybe someone involved in that extension, or someone familiar with it can answer this. I cant help :confused:

ok, thanks for the effort, maybe ill try to contact someone more familiar with that!!

if you write to clipboard then you can use it. only cross platform didnt work for me.
maybe you should download the 2p2 networking example. there the Clipboard::ReadText() is still working.

i didn’t undestand 1 word you just said!

download the example

Thank you so so much!!!
I was searching for a solution for days before I asked it on the forum!!!
Thank God you exist!!!

1 Like

I know this is an old post, but if someone has the same issue:
GemDev used the Clipboard module Version 0.0.1 in his tutorial which still included the “Read” function.

If you install it now, Version 1.0 this function is not included anymore.
I don’t know why, but that’s why this is happening.
You can copy the old clipboard module from gemdev’s sample project, to be able to use that function.