[Solved] Enemy copies get stuck

Hello Everyone ,
I have created an enemy that works fine when dies plays death animation and gets deleted however when I make multiple copies or duplicates some of them when their health gets to 0 they don’t get deleted or play death animation , they only get stuck running in one place , I tried searching in many places but couldnt find answers for this specific issue .
Many thanks in advance .

It will help if you post a screenshot of the delete events. It could be a trigger once issue or you might need a for each object. It’s tough to tell without seeing your events.

Thank you very much for the response Keith , sure I ll attach a screen shot , Even some of the enemy copies work fine but some of them get stuck , everytime I open it randomly happens

Not equal = to 0
But less or equal =< than 0

1 Like

On your 2nd to last event where it checks if health <= 0, I think the trigger once is preventing more than one death at a time. Trigger once events need to go from true to false and then back to true to trigger again.

Try replacing the trigger once with animation not equal to EnemyCrowDeath

1 Like

Yesssssss it worked . trigger once was the issue , many many thanks you are amazing ^^ , i was dealing with this for many dayssssssssss .

1 Like