[SOLVED] Export failed and buttons are not responding

Hi, I’m having trouble exporting my game. This is the first time I have tried to export it but I can’t. When I try to export it to an android device, an error appears when compiling in the last stage (as seen in the image). When I press to see the process log it does not issue any action.

When I want to export to windows as an apk it ends all the steps but when I have to press on “windows.exe” to download, the button does not issue any action either.

This happens to me with several buttons inside gdevelop, as in the help.

The game size is bit less than 100 mb and it has a package name and is different from the default one.
Does the same thing happen to someone?

Open the game properties and fill all the fields.
Then go to Icons and generate the icons.
Then go to Resources and right-click in the list to remove unused/invalid assets.
Then try again.


Thanks for the quick reply. I hadn’t noticed I had to modify that. Anyway, when I click on icons or resources, the game’s properties section freezes, not the rest of the program.
I uninstalled Gdevelop and reinstalled it but they are not responding either.

What OS and version of GDevelop are you using?

I use Windows 10 and the Gdevelop version is 5.0.0 - beta 107. I managed to do as you told me, I had to leave it loading a lot of time by clicking on icons and resources (I suppose because my computer is slow). The problem now is that the download button does not respond, like many of the buttons in my program.

For example, other buttons that do not work for me is on the homepage when I click on “community forum” and in some sections of “help and documentation”. Until now it had not affected me because those sections were not essential for me. But this button is essential :grimacing:

I think this might be related to your browser/Windows preferences.
Open Windows Start menu, and find the default app settings.
There you can choose your default browser (to open Web and html links). Change it, reboot and try again.

It happened once to me. I solved it by clearing the browser cache.

That was exactly the problem, I didn’t have a default browser set up. By setting it up, all those buttons respond and I was able to download the apk. Thank you very much @Gruk :grinning: and also thank you zutty. You can mark it as solved now.

1 Like

Great :+1:

You should have the permissions required to edit your own topic.
Do it yourself next time, please. :slight_smile:

1 Like

I thought that only some users can mark it as solved. I don’t know where it can be marked, i will take a look, and I already know for the next time haha :grimacing:.