[Solved] Export file too big?


I couldn’t find an answer anywhere, but does GDevelop have a limit on the size of file you can export to a stand alone game? (meaning the auto-installer). My game IS getting a little on the large size at the moment (180mb) and It won’t let me package it like it has previously. Since the last time I used it, all I did was add a boss to my level 3. Now I get an error saying “Can’t export the game. Please check your internet connection or try again later”. I figured it might have been my net or the servers, so I waited 1 hour, then a day, and it’s still doing it. Does anyone have any suggestions?

Thanks for your help!

Pretty sure 180mb should be fine. The first game I ever downloaded in the Games Showcase from another user was around 500mb.

Are you still waiting for the same build to finish and still seeing the same error display? If so, then start a new build because sometimes it seems to get stuck on a build and never completes it but if you start a new build it might upload it straight away.

It never even starts the build. I hit the “Package” button. It waits 2 or 3 seconds, then the error pops up. It never counts against one of my builds.

I’m not sure what it is then. A more experienced user might be able to shed some light on things. I haven’t tried packaging a build for around a month.

Have you tried to export a sample?
If that works there might be some incompatible elements in your game, Maybe caused by the recent update of GD.

I didn’t try exporting a sample before. But I just did, and I still get the error on the sample too. So I guess it’s not my game.

it still packages as an HTML just fine though. But wont for the windows auto-installer

edit: also just ran as admin (in case it was a permissions thing), still doing it :confused:

ohhhhkay. so I guess I should have tried this first. Uninstalled Gdevelop and reinstalled it again. Now it’s working. Sorry all ><

The fact you can’t package an sample is anoying.

Did you use the lastest beta 100 ?
The export build service is always up to date with the lastest build.

Also if the error show you an error so fast, i think it’s because the package can’t be done and send to the build service.

This can happend in lot of situation, like you have no enough right for write on your OS, the ressources are missing or can’t be read or corrupt but also one millions reasons.

Your internet connection have some trouble? Like loss of packets or the internet is unable to reach the server (some countries can lock the DNS used by the build service, in this case read about vpn or proxy)

About the limit of export, there is no limitation in term of size for send your game on the build service.
1Gb should work.

I recommand you to clean your temp folder on your OS.
The game are zipped and stored in this folder before to be send to the build service.

1 Like

Thanks for all of the info!. I was able to get it working by uninstalling/reinstalling. I had thought because it said I was up to date, that I was good. But something must have been conflicting. But in the future, i’ll keep my temp folder clean before uploading, just in case.

I think your version was not up to date or corrupt.
This can happen when the application is restarted too fast while the automatic update is not finished.
In this case files are missing and the application has various problems because the installation it is not complete.

1 Like