[Solved] F11 Toggle Fullscreen doesn't work on Linux Mint 20.2 Uma

The game is resized, but the window isn’t, is that it?
I see that the preview window only has the exit button, no minimize and maximize.
Has this always been, or has this issue appeared recently?

Yes, the window isn’t resized and minimize and maximize button has been removed. In 5.0.121 version it does have and full screen does work but the latest new one NO!

1 Like

Thanks for the information, I have forwarded your issue to the team.

1 Like

Which environment are you using Cinnamon, Mate or Xfce?

Another user confirmed that GDevelop is working fine with this specific distro.
I’d recommend the following steps:

  • Update/reinstall your graphics drivers
  • Try the latest GDevelop (v5.0.124)
  • If unsuccessful, go back to v5.0.121
  • If successful, try v5.0.122 | If unsuccessful, try another desktop environment.

And let us know what worked and what didn’t.

Cinnamon actually like a 2 years now.

I got cheapy Amd ATI radeon Powercolor HD 7770 that has no updates!
When i’m back to v5.0.121 that F11 fulslcreen works except for having other issues with bugs between players and vertical moving platform before fixed in latest version of gd5. Only way is bring Minimize and Maximize button back!

GDevelop itself and the preview and exported games are running inside Chromium which has a built-in feature to hide the tool bar in full-screen mode. Wondering if somehow it is causing the problem.

You can toggle full-screen mode using F11 or Fn + F11 on Windows and Linux and Control + Command + F on macOS. Try it. Maybe it helps.

Well on exported game, the full screen does work at all when in event you activate fullscreen only because f11 toggle hotkey is not available.

Please try both 5.0.121 and 5.0.122 and tell us if fullscreen works in both.

5.0.121 does work but 5.0.122 and latest doesn’t. When only in preview mode. And exported it hasn’t f11 hotkey but does have minimize and maximized button.

Thanks for confirming.
Unfortunately, it would seem the issue is on your end (Linux + old GPU). :confused:
The only tips I can offer are trying other drivers, or a different GPU or a different OS.

Alright then. I shall put this word “[Solved]” and keep this opened for the future solution. Thanks.

I don’t know if this helps, but I was having the same problem on Manjaro Gnome. It started after a gdevelop update (I don’t remember which one) and not a Linux, but I was having the same issue as you. Fullscreen mode starting fine, then after the update, the game going fullscreen but not the window, with no obvious workaround.

Weird thing was gdevelop itself would still go fullscreen, and since it’s also technically just a web app, I figured it might be interfering with the game window. Sure enough, if you go into your preferences and turn off “Always display the preview window on top of the editor”, it solves the problem with seemingly no consequences.

Not entirely why this is, but I guess I was right about the web app infrastructure interfering or something lol. Tell me if that works!


I have Ubuntu. And had the same problem after updating gdevelop. I was waiting for each next update to solve this problem. But I still decided to deal with the issue.
Thank you very much! Your solution works!