[SOLVED] How do I Disable touch or cursor press

How do I Disable touch or cursor press…

Bear with me as im not really good at english but i have an external layout and also an external event where both is related to each other. So in the external layout is like a menu with buttons and sprites. So in my external event, there will be functions where if menu button on the top right is press, then it will show up the mini menu.

What is the expected result

What should happen is if i press the top right button for menu then a mini menu (from the external layout) will pop up which is handled by hide and show sprite action ( I also used opacity before this). And i can use the buttons inside the main menu but whats behind the menu, i wont be able to press.

What is the actual result

In terms of it popping up and closing the menu, it works. But i can still access buttons inside the menu even though the menu is not visible.

Another question

I added a layer in external layout but why the layer that i added in the external layout is not showing up in the list when i use action “show layer”

When you check for a main menu button press, also have the condition to check that the mini menu is not visible.

Hello Mr Men, i tried doing that but it does not seem to work. I used tween opacity, hide/show and normal opacity but i still can access my mini menu buttons even though i have not press the top right button to open the mini menu. So sorry for the confusion.

You changed opacity and so you should check if opacity is at something
Hide and show actions are something different
Think of it like sound is playing or not vs volume of sound is 0 or 100
Not the same thing
Yet for you it may seems it is

You should put them on separate layers
And hide/show layers
Then simply for each menu as parent condition use SOME layer is visible

I have put the mini menu in a different layer in my external layout but when i applied it into my external events, that layer was nowhere to be found…

Below is the layers in my external layout (mini menu is under “menu” layer)
Screenshot 2024-05-03 151324

Below is the event when i want to hide layer but the “menu” layer is not there… only have UI and Base layer
Screenshot 2024-05-03 151357

Did you try creating menu layer in your scene and not external layout?

Yes, but still could not detect my layer… It can detect if i use show layer in the current but not inside the external events

Are name of layers are exactly the same?
Including capitals so like
Menu Menu
menu menu
menu Menu
Menu menu

Make sure the scene associated with the external events has the layers. You can change the associated scene by clicking this icon image in the top right of the external events editor, and selecting the scene with the extra layers in it.

Oh thank you for this information! I got it fixed by just setting it to a different variable but this increased my knowledge about the layers and scene association!