[Solved] How Do I Fix The Y and X Offset On All Platforms?

Hey thank you again community. I think one of the most frustrating things is not being able to just Google an immediate solution to a problem.

It’s possible I’m just not directing the terminology correctly.

Here’s the screen shot. I would like my Player/Actor to be sitting directly on top of the Platforms. It seems to be off axis by 32px towards the right and the bottom… so if I’m walking, it looks like I’m in quicksand, and then reaching the edge, I can walk completely away from the graphic yet not fall off, hence my guess is also about 32px off.

Help please? I’ve double check my Events and Their Behaviors. It’s possible the problem is somewhere deeper. Can someone give me directions on how to get under the hood. Thank you!

Also, the Enemies are floating, I would like them to have gravity effect. I’ve basically covered the whole Tutorial. And that is my level of knowledge currently.

Right-click on your player object, and choose Edit object. There you can edit “hitboxes” (to define the collision limits of your sprite) and “points” (to define specific points for your sprite).
There’s probably something wrong with your hitbox.

Thank you Gruk!!

So I thought I looked into it, I did check the Hitbox…I overlooked the HitPoints! I adjusted the pixels. As I stated, It was off 32 x 32, so I (-32) the Y and X coordinates and in the Points setting, as you stated.


1 Like