[Solved] How to disable auto update in GDevelop?

I’m using Gd beta 100 and I don’t want to update to any recent version so I checked disable auto download and install updates but every time I go out of Gd it just updates it regardless of whether I have “disable auto download and install updates” active or not …
.
Is there a way to fix this?

1 Like

That’s weird. You can try to modify the shortcut to launch GDevelop with the argument -disable-update-check. Why do you want to stay on an older version btw?

1 Like

@arthuro555 That’s a cool solution, I added in the target after a space … hopefully it’ll make it work.

I started working on puffball with beta 50 I think (could be 40), so I was updating since then and suddenly after beta 100 I get weird problems that I just don’t have the time to fix so I just thought to stick with beta 100 as it’s very stable for the game and I’ll update when I work on newer project.
And I almost don’t really need any new stuff from the new features as it’s not used in puffball.
But will definitely check it out with newer upcoming projects.

1 Like

I just had this same problem, i didn’t wanna update but it updated anyway.
Does anyone maybe know why this button doesn’t work correctly?

It works for me, I also downgraded to v127 because I don’t like two visual changes they made. Did you try that in post #2? An alternative could be a firewall rule.

1 Like

Thank you for the response. I haven’t tried that argument yet but will do so.

I do wonder why the button isn’t working correctly though, it did switch to a “grey” state and has been like that for a while. Maybe a little bug? I will also keep in mind the firewall rule in case the argument method doesn’t work, thank you for the idea :slight_smile:

Did you maybe open a second instance of GD to copy events, etc.?
A second instance is always opened with the default preferences(:roll_eyes:) and there is the Autoupdate On. That’s how I got unintended updated twice today.

1 Like

I might have had, but I did an instant check on that button and it was indeed grey (in the off state).
But it might still have had the defaults loaded if you say so. Any idea why it loads the defaults and not your own settings? I did add the argument so I hope that works next time :slight_smile:

Unfortunately not. This has been known for several years. The official answer is, GD does not have multi-instance support.
Maybe there is hope now, with the new Dev employees.

1 Like

I had switched auto-download to off, 100% sure. It was switched back on and i got the new version , which preview does not work…

where do you write that line?

Like this: