[Solved] I can't export my game :( Error: 'local-file-download'

Please help, I can’t export my game and I’m really worried I’ve permanently broken it :frowning:

Hello, OurfDev

Did you follow the instructions? All resources of the game are valid in the Resources editor?

how do i check or know which ones are valid?

Openning the resources you can click with the right button of mouse and choose the options “Remove resources with invalid path” and “Remove unused…”. It will not delete the files, but just remove from your project.

You can also search for them in your list and you’ll find them with this icon if they have invalid path and manually remove 1 by 1, but obviously it will take a lot more work:

I did that, but it still wont work :frowning:

So, I’m sorry but I don’t know how to help. I hope someone with more knowledge can help you.

okay, thanks for your help! I hope someone else can fix the problem.

If you look through your resources manually, you may find one that has not been recognized as invalid. But the image would look wrong…

okay, i’ll try that thanks

there was none of them :frowning:

And you removed the ones you didn’t use?

well that was the one i did there was no remove resources with invalid path like @Rasterisko said.

One are the invalid ones, the other are the ones you don’t use effectively… maybe that’s where the problem is

1 Like

oh okay i dont really know much about this stuff sorry

Me neither, but I had the same problem with my first game :wink:

Oh really, thanks for all the help you could give!

Also check the size of your project. I have had the same or similar issues when my projects get to big. I believe Electron (GDevelop creates Electron apps when exporting) has a limit of 1 GB. I use a lot of video in my projects so they tend to reach the limit quite fast.

Good luck


Sorry for the late reply,
I use GDevelop Gold, the assets folder is 110 MB, and the .json file is 2.14 MB.

I fixed it!!
There was a font that it didn’t recognize I think