[Solved] InAppPurchase: unsupported version of Play Billing

I have the same problem. Does nobody have a solution for the problem yet?


Does this work? [WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free]
I changed the Cordova plugin version, but didn’t tried anything

1 Like

Commenting here cause I also would like to know in case that I ever add in-app purchases

1 Like

Hello, just tried it. Installed the modified extension, made a new app bundle, then loaded it onto Google play console and lo and behold it works. Many Thanks. Am happy.


Wow! I thought changing a number was not going to solve anything :sweat_smile:

If anyone else test it and confirms that It works correctly, tell me and I will submit the change to the official extension

Hi, I am having the same problem.
Can you please specify the steps that need to be taken so that the app bundle is approved for the play store?

Try this custom extension: https://we.tl/t-iz1Xlp54ot If it works, let me know

1 Like

Thank you DHsw!
Play Store accepted the version of the custom extension.

Did you have tried it and works? @Jeromck

Hi and thanks to all :smiley:
Today I’ll try your solution and then I’ll notify you if it works :wink:

I tried and all seems fine!!! :smiley:

Really thanks!

Sorry for the delayed response.
I have been unable to test the app since I can’t open it on an android device.
I get a black screen with the cordova logo.
I will post this issue as a new post to see if someone has a solution.

You are installing the apk directly or through google play?

If you can open it and shows cordova logo, it means there’s something wrong with the cordova plugin, the extension code or an incorrect plugin parameter.

Yes directly from Google Play.
It seems that other users have encountered this same problem since the last update.
I posted this issue as a bug here:

I think there’s no needed to open another forum thread for that. Respect to cordova, you’re using cordova and executing cordova every time you open a gdevelop game in android or ios, so yes, you’re using it, since without it, your game could not get executed. Just try to load a website without any web browser. It’s probably impossible, or at least without modifying anything.

This black screen means the custom extension is faulty, because something in the cordova plugin code changed or was added that causes such problem. The solution is adapting the extension code to the new cordova plugin version

I will try to reproduce the problem, and open an issue in github with logs and the corresponding information.

For those people who doesn’t knows what’s cordova: it is a famework. It allows gdevelop games execure in android or ios (like if it was a web browser). It also works as a wrap, allowing gdevelop games having access to native technologies like camera access, sensors, or other sdks that only have support in native platforms, like admob ads, and in this case, google play IAP.


Sorry for the delay there, we’ve updated the IAP extension so it should now work using the extension you can find in GDevelop directly :slight_smile:

@DHsw in the future please don’t hesitate to open an issue/pull request on the extension GitHub repository to suggest your fix! :wink:


Really thanks… and Gdevelop is really a great tool! I love it! :smiley:

1 Like

Sorry, I completely forgot about It :man_facepalming:

Could you please Resend this file. The link is expired