[SOLVED] Issue with Dialogue Tree (Confirm Option doesnt lead me to other nodes)

Hi, I’m having some issues in changing nodes after options using the dialogue tree feature. I saw I’m not the only one with this problem so I tried to download other project and seems there’s something I’m missing. Can you guys help me?


This is from the Dialogue tree example:

You seem to be missing the first condition.

Thank you for the reply
I added the condition but still doesnt work, I can select the option but I can’t confirm it.

Then perhaps the problem is with whatever comes next (another node?). Check for extra spaces, line breaks, etc.

Still no luck. I also tried to compare my nodes to the nodes of a working example but the issue doesnt seem to be there.

Your best bet is to open the example project and compare your project with it to find what’s different. I can’t spot the problem from your screenshots.

1 Like

Ok, I solved the issue, I still don’t get the logic behind this feature but apparently it’s really important that the events follow this order.

Thanks Gruk for the help and sorry for the trouble.