[SOLVED]...messy storage

Basically i don’t understand if it’s my fault or not…
here i expect the condition to not trigger if the group “SAVESTATUS” do not exists, instead for some reason to me unknown the action is triggered anyway…
any explanation on what is wrong ?

the game is loaded even if the group don’t exists…

Not to point out the obvious, but you sure it dosent exist?

Created files or saves dont get deleted when the preview is closed, they stay in your project folder the same way it would work if you game was already exported.

They arent “temp” files, and if you dont delete them when closing preview, they wont go away.

This is so you can test saving things like option settings or save files for you game.

…i mean, im pretty sure thats how it works.

So have a look to see if that file exists somewhere in your project.

I cleaned the file storage before launching the preview.I don’t think there are other location where the file could be …but i don’t know

Ok try this, make an event just above that one that checks if the file exists, if it does, then run the action to clear that storage.

If the event below still triggers then theres something else going wrong.

Try that and let us know :slight_smile:

…it is triggered anyway… :expressionless:

That is just weird… no idea whats going on… ill give it a try.

1 Like

I dont get it… iv tested all of this, and its working as intended.

Are you 100% sure theres nothing else interfering?

If i save the text, dont clear the group and then check if it exists, the sound plays.

If then i restart the preview but dont create or delete the group, the sound still plays because the file still exists.

If i clear the group, the sound no long plays…

so i dont know man… try restarting gdevelop maybe? Or check if theres isnt something else getting in the way?

but trust me, that is my main scene, and i don’t have any save/load conditions except the ones shown above

can u try a chane to scene action?..just to be sure

Sure ill try it, but if the sound action works, the change scene should too.

1 Like

I just tried, i even added variables to be just like yours, it works as intended.

No clue why yours is doing that…

Can you add a “Play a sound” action to your change scene event? put it right at the start, just to make sure that its that specific event thats changing your scene and not something else.

Then if it plays the sound, try changing the sound to the “Delete Storage” event and see if the sound is being played, if it is, then the storage is being cleared and theres some buggy stuff going on…

Try it and let me know! Im so curious at this point lol

thx dude…really…at this point i dunno waz happenin.

1 Like

Try the sound test, it will tell you without a doubt what which events are actually being triggered.

Its my favorite method of debugging event, it always works :slight_smile:

1 Like

oh wait…i right clicked on the gds slort in debugging and now the storage is really gione…
it’s working now…lol

right click on the storage (not the cache) and delete…

i dunno what happened but thx for the support

1 Like

Take a screenshot of where you clicked and such then post it, so that other people with the same issue can what you did :slight_smile:

1 Like

…btw first time i had to do it