[Solved] Mobile | Disable Virtual Keyboard

A) The Issue

  • [Mobile | App & Browser]
    When I tap on my ‘Text Input’ Object, an unwanted Virtual Keyboard appears.
    This obscures half the screen on Mobile, and forces the game resolution to shrink on Mobile Browsers.

  • How do I disable the Virtual Keyboard, without setting the Text Input Object to ‘read-only’?


B) Screenshots

  • My Multiplayer Lobby.
    The Text Input Object (TIO) is the small light grey rectangle, within the large black-filled rectangle.

  • [Mobile | App & Browser]
    When I tap on my TIO, an unwanted Virtual Keyboard appears.

    It is unwanted because the TIO is only meant for copying and pasting, no typing is required.
    Not only is the Keyboard unneeded, it also takes up a ton of space.

  • [Mobile | Browser only]
    When attempting to copy/paste on the TIO, the game resolution shrinks down, as to not be overlapped by the Keyboard (which I don’t even want in the first place).

    Again, this is undesirable.

  • [Mobile | Browser only] cont…
    The game resolution doesn’t fix itself, even when the Keyboard is retracted.

    On some OS & Browsers, the resolution can’t even be fixed by reopening the tab. (Tested on Safari via iOS)


C) Conditions for the Solution

  • The Keyboard should be disabled.
    I believe this would also solve the resolution shrinkage problem on Mobile Browsers.

  • The TIO should not be set to ‘read-only’.
    While it’s true that ‘read-only’ would prevent the Keyboard from appearing…
    … When the TIO is read-only, users on Browser (PC & Mobile) would have no option to paste into the TIO when attempting to Join a Server, since Browsers have only restricted access to the Clipboard.

  • [Alternate Solution (if possible)]
    Setting the TIO to read-only, so to disable the Keyboard…
    … But somehow also enabling Browsers to access the Clipboard for copying and pasting.


D) Game Link


I’ve agonized over this problem all day, but am no closer to finding a solution.
Any help would by MUCH appreciated. :man_bowing:

Can anyone help?
I’m really stumped on this issue, and I’m sure the solution would be of use to many others.

I can’t help but you could try the extension called Clipboard. Maybe you can use it to bypass the keyboard popping up somehow. Good luck.


Also this, it has a Close mobile keyboard action. Sorry if I haven’t read your post properly and you’re already using it.

1 Like

Thank you Bubble for replying!
It’s good to not feel like I’m screaming into a void. :smiling_face_with_tear:


Actually, I’ve already had both extensions installed.

  • The ‘Clipboard’ extension is wonderful!
    It works perfectly when the game is exported into Apps for PC & Mobile.
    However, it doesn’t work on Browsers…
  • The ‘Mobile Virtual Keyboard’ (MVK) extension only works on ‘Text Entry’ Objects…
    …which are different from ‘Text Input’ Objects (TIOs).

I’ve even attempted to modify the MVK extension’s Behaviour Functions to work on TIOs.
But I haven’t managed to accomplish the desired outcome.

Also, I can’t switch my TIO into a Text Entry Object.
This is because the latter doesn’t have an Input Field, which is required for pasting text on Browser.


One way I’ve managed to disable the keyboard, is by setting the TIO to ‘Read-only’.

Meaning that while users may still copy text from the TIO, they can’t paste text into the Input Field when it’s Read-only.
Yes, this disables the Keyboard, but ultimately renders my TIO unusable on Browser. :face_with_spiral_eyes:


Sadly, I’m still stuck on this issue.
But thanks anyway for trying to help! It means quite a bit. :blush:

1 Like

The ‘Clipboard’ extension doesn’t work on Browser…
…But pasting can still be done onto a TIO by Right-clicking/Tap-and-Holding the Input Field, then selecting ‘Paste’.
This method would probably never work on ‘Text Entry’ Objects however, since they don’t seem to have an Input Field.

I’m not sure if there’s a way to paste text into any Input Field, without necessarily also triggering the Virtual Keyboard on Mobile…
…unless the Keyboard is suppressed somehow. :thinking:

Hi again, I opened your game in my laptop browser, copied the server id and sent it to myself and then opened the game on my android phone and pasted in the code and the game went back to full screen after I dismissed the keyboard unlike what you experienced above. It seemed like everything worked correctly for me although I didn’t actually play the game.

I also tried to think of a way to just use a button to paste in the clipboard code. My idea was to touch/click a paste button and then the content of the clipboard (I typed and copied a word into a text editor first) would paste into a text box. I tried pasting to the input box as well. But anyway, when I clicked the paste button it just made the two texts change to zero/0. I don’t know what that means but clearly something wasn’t right.

And the text input object wouldn’t even let me type into it in my laptop browser but did in my phone browser. Which isn’t relevant to you, but anyway.

Here’s what I tried. That’s all for me, bedtime, haha.

1 Like

Try this:

Make sure to select your input object at the top of the JS event.

JS Code to copy paste
objects[0]._renderer._input.inputMode = "none";

OMG, This ACTUALLY Worked!!! :astonished: :laughing:

I can’t even… TQTQTQTQ!!! :heart_eyes: :smiling_face_with_three_hearts:

I can now die a happy man. (jk, lol!) :innocent:

1 Like

Bubble, Arthur,

I REALLY can’t thank you guys enough! I’m forever grateful! :blush:

Also, you dropped these: :crown: :crown:

1 Like