[SOLVED] New object type won't shoot bullets

I have a class called shooty, and all objects in this class will shoot after their cooldown is over. This method worked fine for 2 object types, but I added a third one and it won’t work with it for some reason. It just doesn’t shoot the bullets, but through testing I have confirmed that the code is getting run for it. Anyone have any ideas?

Is the third object added to the same Group?

It is, and I checked all of my code and can’t find anything that would delete the bullets : /
EDIT: Nevermind, see my other reply

As @UlisesFreitas commented, confirm the 3rd object has been added to the group.

If it has, how does the value of BulletSpeed compare to the other 2 objects?

If that’s similar, have just the 3rd object on the scene, run it trough code analyser, set a debug stop where the bullet if created and confirm the bullets are getting generated (their count will be greater than 1). If they are generated, check their position (x, y & z-order).

Thanks for the reply, turns out I’m just stupid though, and I didn’t give the turret the FireBullet behavior lol