[Solved] Pixel Art is blurry

All pixel art I load in, even at 1:1, appears soft.

I’ve found posts from 3 years ago that says:un- check “Smooth the image” - but it doesn’t seem like that option currently exists.

Any ideas or suggestions?

1 Like

I’ve also had this problem before. :smiley:

Here is how you un-smooth the images.

  1. Open Project Manager →
  2. Game Settings →
  3. Resources →
    It will show all the assets in your game. You can now un-check the “smooth the image” option for each image.

Thanks! It works!

It’s a little cumbersome that each item needs to be selected and then shut off - especially considering image sequences. But it gets the job done!

thanks again!

Is there a better way to do this in 2022? I imported a sprite sheet with over 100 frames via Piskel and going through each individual frame in order to turn off the smoothing seems ridiculous!


In general, please don’t bump multi-year old threads markes as solved. Changes between versions may have made the old post no longer accurate and bumping it could cause confusion.

As far as your question, if you change scaling to nearest neighbor in your game project properties, any new assets added will automatically have smoothing turned off.

There is not anything that will bulk disable smoothing on existing assets, however.

Your best bet would be to recreate the object and reimport the sprite sheet after changing the above setting. Hope this helps!

1 Like