[Solved] Player animation broken after update to 5.3.196

After updating to 5.3.196, the player animation got completely broken. In my platform game, the player object uses a lot of different animation actions, such as pause animation, resume animation, set animation to a specific frame etc. It also has different animations that change from one to another in a finite state machine system, depending on what the player is doing (jumping, falling etc). It was working completely fine until version 5.3.195. The problem started right after the update.
But it was solved when I downgraded it back to version 5.3.195. There is definitely something in the new version that is messing up with my player animation.
I wonder if there is a way to keep developing my game with GDevelop 5.3.196 without having to rebuild the player object from the ground, but for now I’ll just stick to 5.3.195 and turn off the automatic updates.

The bug has already been discovered and a fix created 45m ago:

A new release with the fix will be coming very soon.

1 Like

So in short, the bug was just in 5.3.196 not in 5.3.195?
Glad to hear that it is fixed.

1 Like

Sounds great! I’ll update it soon as the fixed version is available. Thank you!

Yeah, only in 5.3.156. But that’s nice that they found a solution.

I take it the update hasent been released yet since the issue is still happening.

I also noticed its mostly with 1 frame animations, doubling the animation makes it change properly.

Hope you guys can get this fixed soon!

1 Like

5.3.198 released, please try again with that patch to make sure the issue was thoroughly patched.

1 Like

I’ve just updated and the issue was fixed in version 5.3.198. Thanks! :grin:

1 Like