[Solved] Read values or strings from storage


I am using GDevelop-5.0.0-beta88 on Linux Mint 18 Cinnamon and have a problem with storage. I can write values and strings but can’t read them and store them in scene variables.

In test mode I use developer tools window, and I can see that values and strings are in the storage file, but when I want to load them into variables, every time the values return 0, meaning they didn’t load from a storage group. I am careful to use only scene variables and strings for text storage, or numbers for value storage.

I included screenshots of a simple test event that should load stored string from one scene to another, but in my case, it just doesn’t work. Hoping this is just some mistake from my side, but it seems to be a bug.

Best Regards


Hi there,
Not sure if that’s the source of your problem but “store as text in” is expecting a string variable, so no need to specify that.
Have you tried the save-load storage example on your system?

Thanks for the reply. You are absolutely correct, that was the problem, Excuse my dumbness! :crazy_face:
Thanks again and have a nice day

1 Like