[SOLVED] Scene Suddenly No Longer Works

I’ve been working on this scene for hours, previewing to test it periodically as I went and it’s been fine. I JUST finished it and suddenly the first round of commands don’t work. The last thing I did was add a new animation to an object (I even deleted that animation once the preview stopped but that didnt fix it).

That’s the first chunk of code, it’s identical (I copied this from another scene, many of the objects are global and I was sure to update the actions to the appropriate objects to this scene) and it works in another scene and it WAS working here and now it’s not. It does the first chunk of actions but pressing the return key doesnt do anything anymore. It just stops there.

I’m kind of losing my mind here because I’m supposed to be presenting this tomorrow and it was working fine, I cannot figure out why it suddenly doesn’t work. I even tried exporting it just in case it was a preview issue (I saw some bugs in the other topics about preview suddenly not working) but its not working in the export either. Previewing it with the debugger gives me no additional information.

Would love to have some suggestions!
I dont have any actions that are missing a trigger once. The majority of this scene’s conditions & events are yarn commands, and they’re all spelled right, no typos. I don’t know what’s happening.

Okay so I realized a key press that’s further in the event sheet was still working, which meant there was something wrong with the actions in the that next second chunk of events. After some trial and error it’s the ‘start dialogue from branch’ action. If i remove that, then everything else in that chunk works. But if I put it back in, it doesnt. I don’t understand why because another scene has the same action (but to a different file/branch) and it works, so it can’t be a yarn extension issue? It might be the file itself but I don’t know what might have gone wrong with it.

Found the issue! Somewhere in the main node one of the end >> to a command near the end of the node got separated and nerfed the whole dang thing. Now I know that sort of thing won’t show up in debugger tho!

I’ll mark this as solved but I guess it’ll serve as a cautionary tale to triplequardruple check those nodes :sweat_smile: