(Solved) Skip Scene Button Functionality Acting Weird

I am trying to create skip functionality for the contextual setting scene told through text.

But instead of proceeding to the actual game scene, things are acting really weird when i playtest the game like the gameplay skipping the scene all together(or at least moving too fast for me to tell). But everything remains ok when i disable the skip button and its event functionality.

Here’s what my event editor looks like:

Please help!

try the trigger once condition?

I also had similar problems with texts skipping to the end text immediately.

You can also use timers as well to dictate a minimal time to skip the text

Nope! That doesnt work, basically i am show/hide objects to set the narrative content of the game through text and visual cues. the remaining event sheet is as follows.

I guess there might be better ways to about it, but this is simple, particularly suitable for a noob like me! :slight_smile:

You are not using timers correctly, I suggest you take a look first at how to use them properly

@vivekC I am not sure whether I understood your problem correctly, but hiding a button does not deactivate it. So it may be possible that you are clicking the skip button although it is not visible in the scene. To avoid that you can add another condition “Check if an object is visible”.

OP is not using any timers but the wait action.

Can you post a picture of your scene setup so we can see where everything is at design time. I’m having trouble imagining the setup.

As Drona said, hidden objects can still be interacted with. Does anything overlap?

I rebuilt the scene and now it works, i think the problem was the combination of bad button placement and erroneous loading setting from the previous scene i.e stopping other scenes.

Thanks for the help!