[Solved] Smoothed pixel art

I would like to use pixel art in my project but the problem is, they get blurred, smoothed inside the editor and also in the preview but actually I’d like to have them pixely. The only way I can solve the problem if I open the images in a paint program such as Gimp and smooth the images and apply pixel effect, then export it. This way, I have pixels visible inside GD, but it still not perfect in all cases and require extra steps to do. In Construct 2 we have an option to set sampling to point and have the pixels in preview and exported game this way, just wondering if GD has such feature hidden somewhere?

If no such feature, solution in GD, can I request it? I mean of course I can, but would you consider to implement it?


I do not know if it can help, but new version of Inkscape(0.91), can create pixel art.
Maybe you can advance one step in your production.

Have you tried the “Smooth the Image” option in the image properties? It works in my PC :slight_smile:

LOL I didn’t know about this obvious option in the image properties window.

Thanks for help :wink:

Sorry to dig this topic out, but I did it and it doenst work:

I looked if there was other option but no luck.

That’s weird. “No” in smoothing options works for me… How small is that sprite?

24x24, but I tested larger 64x64 and still the same, no diffrance at all.

hmm yeah and it’s worked even smaller sprites for me… Delete the sprite from images bank editor and upload image again and put “No” to smoothing option.

Edit: I noticed that in native game it works, but can it be that in html5 game it’s not working?

Yeah, I work in HTML5, I checked the Windows/Linux and its the reverse, sprite is sharp no matter what I set. :unamused: :smiley:

so how do we disable smooth image for html5?
i’ve been searching for a while no answer…

Where is this smoothing thing i have gdevelop 5

Go to Project, Resources, and a new tab will appear, there all the links from your objects are gonna be there, if you select one there is going to be a checkbox with “smooth the image”.

If you want all your objects to be sharp instead of blurry, and you don´t want to uncheck everything (is tedious), Go to Project, game settings, properties and then in the scale mode select "Nearest (no antialiasing, good for pixel perfect games). With that done, every single object is going to look sharp.

Project means where ? (I am on my project !) i didn’t find any resources ?

This is the project icon :


And this is where the link to the resources lives:


Click on the project icon, → Game Settings → Resources. Click on any of the image names on the right, and the “smooth image” option will be displayed in the left

Oh thanks ! for helping

Where is game setting ?
(Sorry i got that) Don’t count this msg !