[Solved!] Tiled json file not showing in gdevelop

I’m trying to create a tilemap. I’ve read the wiki and I made sure to embed the tileset. I export the tilemap as a json. The only option is ‘JSON map file (*.tmj *.json)’ , so I choose that but when I go to gdevelop and try to upload that file, I can’t find it in its location, it doesn’t show up. I’ve tried doing both save as and export as, and I’ve tried exporting it directly in my text project folder as well. It’s a very simple map, (I think like 30 x 20 tiles with tiles at 16 x 16 ) and the tileset I’m using doesn’t seem all that large either. I also haven’t put a whole lot on the map, just a couple of layers and randomly placed objects, the whole goal was to test importing it and make sure that at least worked and it doesn’t seem to be. (I also tried making the layer format both Base64 zlib compressed and uncompressed option)

Really not sure what I’m doing wrong here and I’d really appreciate any help! Thank you!

edit: to be extra clear, I did click to create a tilemap object and I did choose the tileset in the atlas image section, and its when I go to choose the Tilemap Json File that i can’t find the file in question.

1 Like

Hello, welcome to the community.

This sounds like you might have let Tiled decide the file extension, which means it likely saved it as a .tmj. I’m not entirely sure why their most recent update decided to make that the default (since it’s literally just a .json renamed). You should manually type your full filename, including .json, then browse to that location and see if you can find it.

1 Like

Hi! Glad to be here!

I def was letting Tiled choose since I thought it would work lol
(For reference these were my options:

But manually typing in .json on my file name worked like a charm, thank you! I also noticed when looking in my file explorer that the previous exports were being listed as .tmj file type, despite both being listed in the extension I originally chose. So I guess that just supersedes the .json aspect when you choose it for some reason. Weird.

Since I’m here I hope its okay to ask a follow up question: I noticed when I was browsing the forums before making this topic to see if my issue had already been addressed, that it was mentioned there is a file size limit for the tilesets. Since gdevelop will only recognize the one tileset per map it makes sense to load it up with as much as you can but I can’t find the exact limitations listed anywhere. Is it a max dimension size, file size, or number of items on the tileset?

Thanks again!

There used to be a max dimension size of around ~2500x2500 tiles, not necessary filesize. That limitation has been removed with recent updates, although I would recommend staying away from getting something like 8000x8000 tiles or anything, because at that point you’re talking about keeping millions of coordinates in memory.

Got it! And that’s for the tileset right, not the map itself? (Not that I have any intention of making a huge map either lol)

It is for the map, not the tileset. For Tileset I think the limitation is still 2000x2000 pixels (well, 2048x2048), same as any other texture/sprite.

Sounds good, thank you again!