[Solved] Topdownmovement animation stuck at frame 0

Hi, im totally new to Gdevelop and game-development in general (i fooled around RPG-maker a little and was doing some data changing in LF2 (C++), thats about it).

I want to create 3 states of movement, walk, run and sneak.
My Problem, as stated in the title is, that my “running” animation is stuck at frame 0.
The animations are sorted correctly and the right animation is shown, eccept its not animated. The animations are set to loop.

I cannot see, whats interrupting the animation.
The Link to my project

upload your proyect folder maybe we could help you better.

but I tell you that I had the same problem.

You may have a conflict with the Rotate option in the player behavior option.

I think that with rotate option the object could have angle = 0 to 360

without rotation the object will only have angle = 0

Please correct me if I’m wrong.

the rotation of the object is disabled.
But if thats causing the problem, i cannot see how the walk animation is working properly and the run animation does not.

Maybe it’s because of the conditions:

  1. walking the player is moving

  2. running player is moving

That’s why maybe you don’t know what animation to choose.

you can do this:

1 Like

That worked!
Thanks man :slight_smile: