[SOLVED]When try to add animation(png) it only shows animation's name

2 days ago i used to add animations normally but then suddenly the animations started to show only animation’s name, i tried to add in many ways but the animation is not showing on the screen

when i try to add to the screen nothing happens.

That usually means the file is no longer available, or isn’t a valid image type. Reload the image into the animation.

Also look at Game settings > Resources tab > right click on images, and remove unused images and images that don’t have a valid path :

image

You probably need to use a better naming for your assets avoid spaces in names, try to name your files like
Player.png or player.png
PlayerIdle1.png or player_idle_1.png

thank you for your answer. we tried to delete the unused images on resources. than we renamed the image. when we add the image on html file (lets say the files name “image”) the file name turns to “mage” here is the html code:

<img src="file://C:/Users/fetem/Desktop/KELİME OYUNU 2204 - Kopya/icycle.png?cache=1664970194491&amp;gdUsage=img" style="max-width: 24px; max-height: 24px; vertical-align: middle;">

as you can see it deletes the “b”

we also tried these but the code in html deletes the first letter of the image so it can not find any image named like that and it gives error

The folders too maybe you need to rename KELİME OYUNU 2204 - Kopya to KELIMEOYUNU2204Kopya the folder structure of your game projects does not have to include spaces or any charcacter that is not
b, c, d, f, g, h, j, k, l, m, n, p, q, r, s, t, v, w, x, y, z
a, e, i, o, u
This is just common sense when I became game developer that was the 1st thing my teacher told me.

oh thank you for your suggestion but we solved the problem also we are new at this thank you for your helping

Could you post how you solved this, even if it’s a brief one-liner? It could help another developer who has a similar issue and comes across this thread in the future.

when we try to add a png from another file, it was asking “do you want to copy this png to this file?” we were saying yes but when we say yes it wasn’t copying properly. than we tried to no dont copy the file. it start to the pngs normally.


thank you all of you guys for your helps :smiling_face_with_three_hearts:

Hello,
it happens when you move the images in a different folder.
Can you open the resource menu to check if the files are visibles ?
image

Thanks,
J

thank you for your suggestion. we did that also when the program ask us “do you want to copy this file to game’s folder?” we choose yes copy but it wasnt copying properly so we say dont copy and its started to work properly. thanks a lot :smiling_face_with_three_hearts:

1 Like