[Solved] Why can't I type in my Text Input?

Hi everyone. I have no idea why this has happened, but all of my text inputs, which have worked fine until now, have stopped letting me type in them. They are not disabled, I double checked, and it also allows me to paste text just fine? I don’t have a way to prove to you that I’m typing, but I’ll provide images


^ the text input when I try to type


^ the text input when I paste text

If someone knows why this is happening, or would like me to provide an itch.io link to try testing the text inputs for yourself, let me know. Thanks!


just a guess, did you by chance check the “read only”- box in the properties of your text objects?

Edit: I assume you did not because you would not be able to paste anything into the field.

If you create a new project and just have a text input object, can you type into that?

If not, are you ale to test the project out on another device? Or put it onto itch.io, check if it works for you, and if not post the link here and we’ll see if it’s the same for us.

I created a new project, and the text inputs worked just fine. I also put it into a different scene and they worked just fine. I tried disabling all of my code relating to the text inputs, but they still didn’t work. I exported it to itch.io and it still doesn’t work for me. If you would like to try for yourself, here’s the link:


(the password is banana)

Just click Sign In or Create an Account to have the text boxes appear. Let me know if it works for you, thanks!

I can’t enter text either.

Are there any behaviour settings on the object that are different to the ones of the new project’s text objects?

I just found the issue! There was a leftover text entry object that I hadn’t deleted that was interfering with inputting text for the text inputs. Very strange, but it works now!