[Solved] Yarn isn't working

I have looked at several tutorials to do dialogue with Yarn for my visual novel. Unfortunately, the dialogue is glitching, taking several turns to load the first line, and once the button is pressed to go to the next dialogue, half the time the dialogue glitches and doesn’t load correctly, stopping before the line completes. How many characters that load vary wildly. I have checked over my code and tried pretty much everything to fix this but to no avail. Am I doing something wrong, or is Yarn on my computer not working. What should I do instead to have dialogue if this is Yarn’s problem and not mine? (Note, my version isn’t updated but my version will not update as I am using school computers)

I have found some solution to this. If you have a typewriter affect applied to your text object it will clash with the typewriter affect you made in the code.
Perhaps double check to see if you have any behaviors on your Text objects!
I had a typewriter affect on mine without knowing (I was copying objects from scene to scene to test dialogue systems) so it clashed with the typewriter effect in code.

1 Like

I think you might be the same person who posted a comment under my tutorial video. But in case you are a different person, here is the solution:

“Have you got the typewriter extension applied to your text object? It’s called ‘Auto typing animation for text (“typewriter effect”)’. It clashes with the dialogue system because you have two typewriter effects fighting over the same text object, producing weird text animation. Remove the typewriter extension (behaviours tab) from your text object and your dialogue system will work as intended.”

Edit: @bobpeterson beat me to it :smiley:

@StupidSquirrel88 Please add [Solved] to the start of your post title, if things are working now.

Edit 2: @StupidSquirrel88 Something else that might be causing you problems is having your ‘dialogue is not running’ stuff as a sub-event of the ‘dialogue IS running’ event. Try making them both events, not sub-events, like in my yt video:

1 Like

I am but not the original poster! I saw your comment today and you were very right!

1 Like

I watched your video over and over again to write this code, thanks for replying! I do have that typewriter extension on my code - I added it before trying Yarn and I never thought that would be the issue. Thanks! This and your video have been really helpful!

1 Like