Sprite's rotation is wrong wtf

The sprite rotates when the mouse is moved but the rotation is wrong, in the picture the red X mark is where my cursor was but the sprite’s rotation isn’t on the mouse, here’s is the code:

Please help. :question:

Have you moved the Centre point?, the default sprite image “looks” at the right? :slight_smile:
If everything looks fine and still doesn’t work, please share the .gdg + the image to check it.

I didn’t touch the center point I tried to rotate the sprite to look at the right before I start up the game but still…nothing :frowning: but… okay i’ll share the .gdg and the image.
project.gdg (30.6 KB)

The problem is that the image is not looking at right, I’ve just rotated the image and now works as it should :slight_smile:

I mean this, maybe you did it but you have to reopen the project, to force GD to reload the images:

Thx man :smiley:, though I have another problem whenever I put a tilemap object then I put some tiles at it then save and close GDevelop then when I open my project again then the tilemap disappears :open_mouth: the tilemap object it still there but all the tiles I made disappeared :cry: , why does that happen?

Maybe you haven’t save your project, be careful if you have multiple projects opened.
You can also send us your project (withh all the pictures).

EDIT : Tiles can disappear (but still here) because of the tileset image not available (because the image path is incorrect).

I was able to create the tiles(because the tile image is correct) then I save the project(I always do that) but I don’t have multiple projects opened as I’m only working on 1 project.

Sometimes I do tend to open an example project if I forgot how to do something but I don’t see any reason for that to affect my main project, as I only take a quick look at the example project sometimes then quickly close it…

If you open an example using the TileMap Object and it works. The problem comes from your picture : you may have forgotten to set up the image properly in the tileset.

Okay I’ll try and see if I set it up properly :slight_smile: