Stop Sounds at the Beginning of the Scene set to OFF by Default

I just spent the last 30mins working out why my “open menu” sound was being cut off when changing the scene…

…then i finally woke up and realized that i forgot to turn off the “Stop Sounds…” thing on this project, followed by going into every scene and turning it off…

I honestly see no reason why this would be “On” instead of “Off” by default, it seems like an option thats better to Opt in then Opt out, since i personally see no reason to ever use it, unless under very specific situations, while having sounds and music transition between scenes is just how games work in general.

So, could this be off by default? Think it would be a nice quality of life change.