Stretch a 3d object

so i am trying to put the map i made on blender into the engine, but when i put it in, its sideways and small, and i can only stretch it sideways and on depth, making it either small or incredibly thin

When exporting gltf from blender uncheck “+Y Up” then the object in Gdevelop will be oriented the same as in the Blender scene. The size of the object itself will correspond to the specified proportions in the object properties - width (X), height (Y), and depth (Z), by default Gdevelop preserves the aspect ratio of the object, you can disable this function here:

1 Like