Stuck when "uploading to build service" on Android build

Hi guys,
Again, I am getting stuck at the uploading screen, please see attached.
The game is 95mb, is there a limit?


I don’t know if your problem is caused by being above the limit or not but the limit of your project if I remember correctly, the limit is somewhere around 100MB.

Thanks, tried a 79mb, still failing.
Is there a way I can get an official answer as I have tried the documentation and cant find anything about it.
I know I can export and use Cordova, but GDev compresses it and turns it into a abb, google take abb of 150mb, apk of 100mb so obviously GDev is a better way to export.


Your last statement doesnt make any sense. The online system is also using cordova.

There is nothing the online build service is doing that you wouldn’t be able to do with Cordova, since Cordova also outputs aab files.

Thanks but I have tried the below 3 commands and its still the same size and its still an apk:

cordova build android --release --packageType=bundle
cordova build android --prod --release --packageType=bundle
cordova build android --prod --release – – --packageType=bundle


Those commands only work if you’ve added the right type of Android API and then use the appropriate version of gradle (gradlew) afterwards. This should be in a gradlew subfolder of your project, not the parent directory.

However, you can read more about it here:

Regardless, I’ve done a few tests with 100 and 120mb projects using the external build service, and both completed successfully, so I can’t really give any other guidance.

1 Like

Thanks, it did it but it took 22 minutes before it showed uploading, sure it used to take 2/3.
No worries, solved.