This could be used to e.g. displaying level name in-game or making scene restarting easier as you won’t have to store scene’s name in two places (actual name and e.g. in scene variable). It would make changing name on a whim easier - you only need to change name in editor.
Indeed that would be nice: I’ll add it. The question now is what name should I choose?
CurrentScene() or CurrentSceneName()?
I think the latter. It’s more descriptive and it isn’t like you need to type it by hand so it’s ok.