The Joystick Gets Stuck on The Top Left Corner of The Screen

When you play the game in web it doesn’t have a problem. The joystick works as it intended. You can check it here.

After that i downloaded the APK version of the game to my phone to test it and i realized that the joystick is stucked on the top left corner(on the web version even if i play it on mobile it doesn’t have a problem) and it doesn’t gets spawned to coordinates of my touch which according to the events i assigned it has to do it.

Here are the events:

So my question is what is the problem with the APK version? Why does it get stuck and doesn’t act as it was assigned in the events?

A number should never be set directly for the touch identifier parameter. The one given by StartedTouchId must be used. That said, you probably don’t need to handle multitouch, using mouse conditions will work directly.
This documentation explains how to do it:

Thank you. I replaced the touch identifier with the StartedTouchOrMouseId() but it still requires me to set a parameter. So i’m confused about this.

EDIT: When i assign the parameter as 0, nothing happens. But when i assign it as 1 or higher, the joystick gets stuck at the (0,0) position as i told even in the desktop version.

Here are the new events:

It’s explained in the documentation. Maybe open the example to copy-paste the events:

I was skeptical, but I did what you suggested and used the example as a model for what op needed to do (I think). I was shocked to see it worked. Thanks a lot, even though it wasn’t my question. This knowledge will be useful to me and now I won’t have such bitter feelings about the multitouch expressions.

Edit I did build an apk to test.

Sorry i didn’t read very well. But i tried that part and adjusted for my needs and it worked! Thank you.

The joystick appears where you click, but if I move it without releasing the click, the joystick does not work, until I release the click and press it again on the joystick.