Tiledmap coordinates bug?

So i was trying the new ver of GD with fixed Tiled map collisions,…and i think to have discovered a bug or an unwanted behaviour.
Basically if you have 2 platformed objects on a Tiled collision map and if you try to apply a force to move e.g the enemy to the center x of player, it will never meet the destination.
It works on GD platform instead.

Imo it looks like it collide with player hitboxes inconditionally or something like that. Reaaaallyy need a fix

This is driving me nuts since i cant trigger …at point… the enemy never meet the input coordinate

Last ver of TILED and GD

I’m not sure if this is your issue but the 2nd “middle” has 2 e’s. “middlee”

1 Like

That is correct since middlee is the enemy y center

1 Like

SRY, I tried on a clean project and it works…
Edit2, Lol, i can’t figure out…
Edit3, : it really looks like coordinates are different when colliding on a tiled mask…

EDIT4: Partially Solved: for still unknown reasons points aren’t 100% working, works with center expressions.

EDIT5: still i think its a bug: if you try to put 2 middle points on 2 objects at the bottom and then trying to make one of the two meet the same x position of the other it doesn’t work on TILED map.
Works on GD platforms. There is a workaround with “Centers” but its not working as intended.

Please delete the thread, it was a missing declared Point in the animation.
It is hard to remember everything.
Sry for the waste of time.

1 Like