Trying to change / set Animation = Preview Stuck?

Hi All,
I’m trying to change the animation when not moving to “IDLE” when moving to “DRIVE

When I move… the preview stuck, I must press ALT+F4 to get back to GDEVELOP. (I use the latest version on Windows 10)

If I toggle disable “Player is Moving” it will work nice, won’t stuck… but won’t change the animation which is what I want.

How can I make it work without GDEVELOP to stuck?

BTW - I also tried to add “Trigger Once” as suggested on discord, but I get the same result.

When you say the preview stuck, do you mean the preview doesn’t respond, or your animation is stuck and not animating?

If it’s the latter (animation not animating) then the problem is because you are resetting the animation every single frame while the player is moving. The condition “Player is moving” will be true every frame while the player is in motion.

You need to add the condition “Trigger once while true” to the “Player is moving” condition. The trigger once has to apply to the “Player is moving” condition. It can’t sit on it’s own. So it should look like:


As I mentioned, GDEVELOP is stuck, not the animation.
Since I’m using fullscreen I can only quit using Alt+F4

If I’m not using fullscreen I can just click the [X] of course :slight_smile:

As I mentioned I tried it with “Trigger Once” already, no difference… still stuck :frowning:

I’ll try to show it in action, maybe it will be easier to point me what I’m doing wrong and how can I fix it please?

Thanks ahead!

Can you make an web export for testing on our side?

Does it cause the same issue of you use the action “change the number of the animation of …”, instead of changing by animation name?

Does the animation “DRIVE” (all upper case) exist? Are all the frames there? What happens if you move the drive animation to the top of the animation list, so it becomes the default animation?

1 Like

I’m not sure why but… it seems like Close and Restart GDEVELOP made it work, the weird thing is that it didn’t happen on the few times I did it, so I hope it is just a bug but also hope it won’t come hunt me again in the future.