Tweens not working on Boss after Intro is done

Hello, so in my game I have a boss intro. After the boss intro is done, then he can start tweening toward the waypoints I put around in the scene. But the boss is ignoring the Tweens.

Tweens have always worked for me with no problems, I can’t see what is wrong with my code

Edit: I have also tried deleting the “Stop tween” to no avail

Hi KulerDeveloper, in your waypoint 1 tween has finished event, have you tried putting in Remove waypoint 1 tween in the action before playing the waypoint 2 tween? You could also try putting a Trigger once in the BossIntroIsTrue condition

bossIntroIsDone,Trigger once → tween waypoint 1
Tween waypoint 1 finished → remove tween waypoint 1, play tween waypoint 2

1 Like

Hi thank you so much for the suggestion. It kind of did something: Boss moves to the first waypoint and then when he is going to move to the next one he stops abruptly!! I think,I’m going to remove the tween behaviour all together. It has never acted so weird on me

I just did a little test and I think you need to make the waypoint 1 and waypoint 2 tweens two separate events instead of event and sub event.

1 Like

Ok I’ll try that next time. Right now the boss has a series of behaviours that work well with the theme of the game and it took some time to code it, so I’m not touching it for the time being.
You can try it here colorpalettetopdown | Play on