Where do I find log files?

I’ve been having an issue lately with gdevelop crashing. It’s happened several times in a row, and it seems to always happen in the function editor when trying to copy and paste events.

I’ve tried searching the forums for the location of log files, but it seems to only return bug reports.

I’m using I believe the latest version of gdevelop 5 beta 100 on Ubuntu Linux 20.
I checked about:support. It showed drivers for webGL 1 but not for webGL 2 (I think gdevelop only requires webGL 1?)

I tried to run $ find / -name errorlog.txt from terminal and got a wierd permissions error. I tried it using sudo and even as root after running sudo su and still no luck… probably something simple I’m doing wrong.

The error was: find: ‘/tmp/.mount_GDevel2EyinA’: Permission denied
Maybe a permissions error because that file is mounted by gdevelop when the editor is started?

I also tried looking in /tmp/GD* but found no log files, only a bunch of .js

Hoping to present something with a bug report other than “Gdevelop isn’t working” but I think I need to find some sort of log report to do that.

Afaik there is no log. That would be a good idea though.

1 Like

Actually there is a log file, but the message logged are not very important.
Here my path for the log file on windows.

C:\Users\RTX-Bouh\AppData\Roaming\GDevelop 5\logs


On an ubuntu system, I would imagine that would translate to the users home directory, but I don’t see anything comparable.

I found in another thread further down the line a topic describing a memory leak. It sounds a lot like what I have going on here. I’ll try running the editor with systems monitor open and see if I can pinpoint a memory leak. It seems to consistently happen in the functions editor so that’s a good place to start. Hopefully I can report back with something useful.

Do a system-wide search for a “main.log” file perhaps, even though what you’re looking for may not be in there.

1 Like

I was able to locate the main.log at ~/.config/GDevelop 5/logs but as you stated nothing noteworthy in there. Only attempts to find an update.

I’ll keep trying to locate a memory leak. Ironically, when looking for it I can’t seem to find it. Keeping my eye on task manager the ram usage goes up and down, but it doesn’t appear to be holding anything. And no crashes so far today. Perhaps an example of Heisenberg’s uncertainty principle? If I watch the ram it behaves the predictably, whereas if I don’t watch it, it behaves erratically :wink: