Why can't I log into the GDevelop web app with my phone?

Hi,

I want to enter the GDevelop web application with my phone, but when I try to log in, a small rotating loading icon next to the purple login button appears and goes away, but nothing happens and I stay on the login window without giving any error and it does not log me in. :face_holding_back_tears:

I also used VPN but it didn’t work. I tested it on PC with and without VPN. I was able to log in with VPN on PC. But I want to login with my phone. Can you please tell me if this is a bug or something else? :sob:

I also tested different browsers but the problem still exists.

What do you think I should do? :woman_shrugging:t2:

:wave: Hi and welcome here :slight_smile:
So you are able to use the web app to build a game, you’re just unable to log in, right?
What’s your device? What browsers have you tried?

Thank you for the welcome. :slightly_smiling_face:

I haven’t really worked with the GDevelop web application very much yet and I have a few other big and small problems too. But I can create a project and, for example, set a scene. :face_holding_back_tears:

I’m using a Xiaomi phone with Android 12. :sob:

I have tested it in updated Google Chrome and Microsoft Edge. :pensive:

Do you have any ideas? :face_holding_back_tears:

Hi xGoldx, I just tried logging in on a Xiaomi phone with Android 11 in firefox browser and it worked perfectly with no delays.

1 Like

Hello Bubble, Thank you very much for taking the time to try to login on Firefox browser. :slightly_smiling_face:

As soon as you said “Firefox works”, I downloaded the browser and then tried to log in, but unfortunately the problem was not solved and I still cannot log in. :sob:

Again, the rotating loading icon appears next to the login button and then disappears, and I remain in the same login window without any error. :pensive:

A quick side note: Unfortunately, in the country I’m in now, internet access is very limited and many sites are filtered. :slightly_smiling_face:

I can’t even load the GDevelop forum without a VPN. Do you think this is the problem? Can anything be done? I think there is nothing I can do. :face_holding_back_tears:

Yesterday, I had a chance to log in to the GDevelop web application using VPN on the Google Chrome browser, but the loading was rotating for about a minute on the login page, then it was logged in. But after a while, when I tried to log in again, I couldn’t log in. Again, the same soup and the same bowl! :woman_shrugging:t2:

You seem to be using a restricted network. Unfortunately, we can’t help you with that. :person_shrugging:

Hi again xGoldx, there might be nothing that can be done from the GD side, but keep trying. Here is where I think the current situation is. You didn’t say the first one but I’m assuming it.

PC
Without vpn, no
With vpn, yes

Phone
Without vpn, no
With vpn, no

Questions

  1. You need a vpn for GD forum. Is this for both phone and PC?

  1. Was this on your phone? If yes, why did it work? What did you do differently?
  1. Were you logged out because you stopped using the vpn while you were doing other things?

  2. Have you tried different vpns?

There’s other browsers too, Duckduckgo and Opera are ‘proper’ browsers and aren’t risky.

Some observations
A few months ago I was using GD on a computer with Linux (appimage) and I couldn’t log in. It would time out and I couldn’t even close the login in part so that I could jut use GD not logged in. So I had to close GD itself. Then I would open GD again and it must have recognised the previous login attempt and I was now logged in. So you could try closing that tab and opening GD in another tab. I know it’s not the same but it is a good thing to never give up and keep trying things.

Bubble Thank you for analyzing my words and looking at the problem from different angles. :slightly_smiling_face:

The good news is that I was able to log into the GDevelop online app with the Tor browser on the phone. :slightly_smiling_face:

The bad news is that the internet here is so limited and unreliable that sometimes I can’t even connect to Tor. Sometimes I can’t connect to Tor even with Tor bridge. :sob:

Sometimes it works and sometimes not. But when it works, it is often very slow and I hardly log in to GDevelop online app with my phone. :face_holding_back_tears:

Recently, access to many services, including Google services such as Google Maps, etc., was restricted. Unfortunately, access to the Google search engine may be interrupted here too. :pleading_face:

But let’s get back to the point. Suppose I am logged into the GD online. (Sometimes I can login). There are still some problems that I am dealing with. :pensive:

For example, I can’t connect to Google Drive in the Tor browser with my phone to save the project. I looked at almost all the topics in the forum about Google Drive and went through them, but I could not solve the problem. :confused:

The error it gives is as follows:

  1. There was an error when selecting a file or folder from Google Drive. Try again later or verify that you are properly connected to Google Drive.

  2. editor.gdevelop-app.com says
    Unable to open the project.
    Google Drive could not be loaded. Check that your are not offline and have a proper internet connection, then try again.

But the answer to your questions is as follows:

Yes, I need a VPN to access the forum on both. Recently, I tried on PC and I could not log in to the GDevelop online game engine even with VPN.

I was messing around with VPN servers when one time a server in Great Britain worked and I was able to login. But later, when I tried to login again, I couldn’t. It was by chance.

Yes.

Yes, I tried two or three of them. But as I said before, most of the VPNs do not work here due to internet restrictions.

Now with the VPN on the UK server, luckily on the phone in Google Chrome, I was able to login to GD online and I was able to connect to Google Drive too. :face_holding_back_tears:

But there is no guarantee that I will be able to connect later. I tried a lot to connect to Google Drive with Tor, but it didn’t work. :woman_shrugging:t2:

Hi xGoldx, I really admire your persistence with this. Amazing effort.

I just did a test with the online editor to see the save options. As well as the google drive save I also have this option:

Gdevelop Cloud (beta)

image


I tested it with a test project on one device and then accessed it on a different device so if that option is available to you then it could eliminate one of the problem areas. Good luck with it all!

Hi Bubble, Thank you very much and I appreciate your help.

Yes, I also have this option, but it has some small problems, for example:

1- The number of projects that can be stored in the cloud is only 10.

2- Only 50 megabytes of resources can be saved for each project.

Of course, as you know, you can subscribe and upgrade it.

3- To use the cloud space, you need to log in to GDevelop, which unfortunately I can’t do very well.

But overall, it’s not bad for a start.

But a question has occupied my mind. That is, as you posted in the photo above, GDevelop has an option to download a copy of the project.

I know it is for the continuation of the project in GD desktop. But why, for example, there is no option to import or directly upload the project saved on the device (such as a phone) when opening the project on GDevelop online app? :woman_shrugging:t2: