Why won't animations play?

I have my character sprite (daisy_puppy) set to sit still at the beginning of the scene, while the setting fades in.

Then, once the tutorial timer indicates that the tutorial should begin, I want the sprite to be able to move around - and for the walking animations to play.

For some reason, the sprite will move around once the tutorial variable is set to 1, but none of the walking animations will play, and I can’t figure out why.

EDIT: all of the animations worked fine before I introduced the ‘tutorial’ variable.

Any help please?

Your event has two animations playing at the same time. Try to remove one of them

I don’t understand - one is for walking left and the other is for walking right. Both of these animations worked perfectly before I introduced the ‘tutorial’ variable.

When animation 3 has not finished playing, animation 0 starts again. Doing so will result in incomplete animation playback. Finally, the animation will switch to animation 0

If you want to play animation 0 after animation 3 is played, you can add the condition that the animation has been played

But you have two left key pressed and two right key pressed conditions with different change animations actions.
If you press right, both will executed. You start animation 2 and animation 0 at the same time.


Did you try putting it At the Beginning of the Scene?
Reset Tutorial Timer
Pause Tutorial Timer…

Then use Unpause Tutorial Timer when you need it… Worth a shot

Also worth trying Trigger once with the last condition (scene variable condition Tutorial=1)… and also try trigger once on the key presses/releases