DialogueTree: stuck after selecting an option


I’m trying to create a visual novel segment for my game using the DialogueTree extension. I have been able to get the text to advance on mouse click, but for whatever reason I can’t get the option selection to work.

At the moment, when the dialogue line is “options,” I create a set of BBcode Text objects, each for each option and containing the option number as a variable. Then, when the player clicks on a given BBcode object, its number (stored in the aforementioned variable) is passed as the selected option, and Confirm selected option is called. But when that happens, the game is still stuck at “options” and doesn’t take me to the continuation of the text. (It does work when I test it directly in Yarn, though, so there should be no issue with the JSON.)

This is the code I’m using:

Any ideas or suggestions would be much appreciated.

P.S. This might be the same issue as this unresolved one reported last year: (Dialogue Tree) Confirming Option doesn't advance to next node?

I would recommend opening the example project and comparing your events with it.
Sometimes, it’s just a matter of event order.
Sometimes, there’s a problem in subsequent dialogues that crashes it.

So, when you hover an option, it turns white, and when you click, nothing happens? The choices are not deleted?
What do you mean by testing it directly in Yarn? Be careful, because not all Yarn features are working in Gdevelop, I think. Stick to what you can find in the example and our wiki page.

Thanks for the suggestion! I did consult the example project (that’s how I know how to use the extension at all). As far as I can tell, the event order seems to be, well, in order. The subsequent dialogue is just a few more lines of text, so there should be no issues. I can’t fully replicate the tutorial, though, for the simple reason that my version needs to be mouse-controlled; but all the basic actions are the same as used there.

What happens is exactly as you described: I can click through the text until I get to the options, then the option “buttons” respond to mouse hover, but not to clicking. The choices just stay there and no further text is shown no matter what I do.

I don’t think there is any issue with the Yarn file (I’m using the builtin version): it’s just text and options, written according to the GDevelop wiki – not even commands or variable manipulation at this point. (I just never got that far.)

So basically, unless we’re missing something obvious, there is either a bug in the extension (it’s still in beta, after all), or the extension is incredibly picky and only works under very specific circumstances, which clearly limits its utility – unless these circumstances can be explicated in the wiki. Whichever the case, I hope there is a solution coming soon that makes it easier to use, since this is such a promising extension. It seems that the author of the August 2020 post never found a solution, though…

I’ve already done mouse navigation, if that’s what you’re referring to (the project is called GDSolver if you want to try). But not with a text object for each option. I used a hitbox object for each option.

Just because there’s an unsolved topic doesn’t mean there’s a bug. :slight_smile:
This should be more useful to you: [Solved] Yarn - A single interaction breaking? - #14 by blurymind

How are you events structured?
Do you have mouse button is released first?

Hi, sorry for reviving a 10 months old topic, but I’m very curious about Gruk’s GDSolver (it does exactly what Im trying to do).
Gruk, would you mind sharing details on how did you use a hitbox object for each option? Im not sure how to place them. If it’s not too much trouble, can I have a look to the project? I would appreciate any insight anyway :slight_smile:

Here’s how I did it: for each option, create a text object, create a hitbox object, adjust the hitbox size to the size of the text, and hide the hitbox.

I did that because I couldn’t use directly the text object hitboxes, but maybe this has been fixed/improved in the meantime.

1 Like

That’s very helpful. I didnt use the hitboxes, (the text objects worked) but your asnwer clarified a lot! Thanks!

1 Like